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A 4510 Software Programming Guide
1.0 RUNNING THE PROGRAMMING SOFTWARE

The software is provided on the supplied SD Card and is called “RedbackA4510TimerProgrammer”.

In order to access the program, the SD card will need to be connected to a Windows based device such as a PC or laptop. 
It will need to be equipped with an SD card reader to do this. If an SD slot is not available then the Altronics D 0371A USB 
Memory Card Reader or similar would be suitable (not supplied). 

You will first need to remove power from the A 4510 and then remove the SD card from the rear of the unit. 
To remove the SD card push the card in and it will eject itself. 

Make sure the Windows based device is on and card reader connected and correctly installed. Then insert the SD card into 
the reader. 

Go to “My Computer” or “This PC” and open the SD card which is usually marked “Removable disk”. 
In this case it is named “Removable disk (F:)”. Select the removable disk and then you should get a window that looks like 
figure 1.

It is recommended to run the program from the SD card. 
Double click on the file - RedbackA4510TimerProgrammer. 
The programming screen should appear as shown in Fig 2. 
If the program doesn’t run then the .NET Framework might 
need to be updated on your PC. 
This must be updated to the .NET Framework 4,  available 
on the microsoft website.

      Fig 1

 Fig 2 
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If this is the first time the program has been run, a new calendar will need to be created. Navigate to the “File” menu in the 
top left corner and select “New”.
The window shown below will appear. The start and end dates will default to the current year with a 2 month overlap into 
the following year. 
NOTE: The calendar start and end dates can be set to a minimum of 1 month, up to a maximum of 2 years.

In our example we will select the default calendar.
Press “OK” to confirm the dates. The window shown in figure 3 should be created. 
This is where all the timing information will be entered for the calendar year.
NOTE: The colour scheme for the calendar can be altered in the defult setup (refer to section 4.0 for more information).

Fig 3
2.0 ADDING AN EVENT GROUP 

The software makes it very easy to enter the timing events for any calendar day. The timing events for a day can be grouped  
and labelled into something meaningful to the user, such as “StandardDay”, “PublicHols”, “SchoolHols”, “StudtFreeDay”, 
“AssemblyDay”, etc up to a maximum of 12 characters.
To add a group, simply press the “ADD” button in the Event Groups section of the window. The window shown below 
should appear.
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For our example we are going to start by adding the event group labelled “StandardDay”.
NOTE: No spaces or special characters can be used when creating the labels. 
Enter the label, select a colour for the visuall representation of the day on the calendar as shown below and then press “OK”.

The Event Group created will now appear in the Event Groups as shown in figure 4.

Fig 4

Before we go any further we will save the calendar configuration. Navigate to the “File” menu in the top left corner and 
select “Save”. 

We will now create the other groups we would like to add. 
We will add Event Groups for public holidays labelled “PublicHols” and an Event Group for school holidays labelled 
“SchoolHols”. We can do this by following the same procedure just outlined or we can use the “Duplicate Event Group” 
option (see section 6.0 for more details).
The result is shown in figure 5.

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the SD card, so all configuration information will be saved to the SD 
card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to navigate 
to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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Fig 5

For our example we will now select the days of the year we would like to generate into standard school days. In the Event 
Groups window select the StandardDay group. Now move your mouse over the calendar and you will notice that the days 
will change to the “StandardDay” group’s colour (In our example this colour is green). Pressing the left mouse button will 
change the highlighted day to this colour and in turn SET the selected day to a standard school day as shown in figure 6 
where February 8th has been selected. We will call this the “Single Day” selecting mode.  To undo the selection press the 
right mouse button on the same day, and the day will become deselected.

Fig 6 



www.altronics.com.auRedback® Proudly Made In Australia6

A 4510 Software Programming Guide
Now you could go through the entire calendar selecting single days but it would be very time consuming. 
You might also notice that if you hover the mouse over the S,M,T,W,T,F,S letters representing the day of the week, that par-
ticular day will be highlighted for the entire month. We will call this the “Same Day” selecting mode. Press the left mouse 
button on these letters to select that day for the entire month as shown in figure 7, or press the right mouse button on the 
day letter to deselect.

Fig 7

It is also possible to highlight multiple days of the calendar. We will call this the “Multiple Day” selecting mode. Press the left 
mouse button on a day to select it, now hold down the shift key and move the mouse over the calendar. You will notice that 
the selected days will flow over the days and months. For the purposes of our example we will select all days of the calendar 
as shown below (figure 8).

Fig 8



www.altronics.com.au Redback® Proudly Made In Australia 7

A 4510 Software Programming Guide
NOTE: In this mode Saturday and Sunday cannot be selected, unlike in the “Single Day” or “Same Day” selecting modes. It is 
also not possible to deselect multiple days so be sure you have selected the correct days. The easiest way to deselect mutliple 
days is to use the “Same Day” deselection process.

We will now enter all the (Western Australian) school and public holidays, using a combination of “Single Days”, “Same Day 
“ and “Multiple Days” methods. The result is shown below in figure 9.

Fig 9

The basic calendar is now setup for the current year as well as the first two months of next year. At this stage additional Event 
Groups could be added for Student Free days, School Carnivals etc. 

3.0 ADDING EVENTS FOR A GROUP

With the Event Groups setup, we now need to program the events that will occur for these groups.
In our example we will program the events to occur on a standard primary school day. Begin by selecting the StandardDay 
group from the Event Groups window. Next press the “ADD” button below the Events window (just above the Daylight 
Saving window). A New Event window as shown below should appear.

          Fig 10

An event can now be programmed from this window. A description of the event can be added (such as Pre bell, Morning 
Tea etc), the start time and the duration can all be entered. There are four options for the output associated with this event. 
The Bell option will play the MP3 audio file in the “Bell” folder of the SD card. 
NOTE: Only one MP3 file is allowed in the “Bell” folder.
The Prebell and Music options will play the MP3 audio files in the “Prebell” and “Music” folders of the SD card. 
NOTE: If more than one MP3 file is in either of these folders, then each time these outputs are activated the audio files will 
be randomly played.
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The last option for the output is the RELAY option, which when used has no audio output, but will activate the Bell and 
Common 24V DC switched outputs.
The first event we will program we will label “PrebellMusic”. We will use this event to play a music track to notify students 
that the first bell will sound soon and that they are to start making their way to their classrooms. Type in the label name, and 
then enter the start time and duration the MP3 is to play. NOTE: The start time is in 24 hour format.
NOTE: The durations for the Prebell, Bell, Music and Relay outputs can all be set to a default time (refer to section 4.0 for 
more information).
We will select the output as the Prebell, so that when this event is activated the MP3 files in the “Prebell” folder of the SD 
card will be played.
NOTE: If more than one MP3 file is in the Prebell folder, then each time this output is activated, a random MP3 audio file  
(from the Prebell folder) will be played.

           Fig 11

Enter all details and then press the “OK” button. The Event should now appear in the events list for the StandardDay group 
as shown below in figure 12.

Fig 12 

The Prebell has been programmed to start at 8:25 AM and play the MP3 file in the “Prebell” folder for five minutes.
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Now let’s repeat the process for the first bell of the day which will 
occur at 8:30AM. We will enter the details as shown in the figure to
the  right. The start time is set to 08:30:00, with a duration of 3 
seconds. The output is set to Bell, which will activate the one and 
only MP3 audio file allowed in the “Bell” folder of the SD card. 

After the details are entered we press OK to confirm, only to receive a error message “Unable to save Event”.

This has occurred because there is an overlap of times. The “PrebellMusic” Event and the “FirstBell” Event overlap at 
08:30:00. If we change the duration of the first event (PrebellMusic) to 4:59, then the first event will finish at 08:59:59 and 
then the overlap is removed.
To change the PrebellMusic Event ,simply highlight this event and press the edit button. The Event window will appear and 
then the changes can be made. Once done, the FirstBell Event can be programmed and saved and will appear in the Events 
list as shown in figure 13.

Fig 13
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To make the programming of the events easier, default durations can be setup for the outputs. For instance you may require 
the Bell to always activate for three seconds. The default duration can be set to 3 seconds and hence whenever the Bell is 
selected as the output for an event, the duration will automatically default to 3 seconds. (Note: This can still be modified to 
any time). To set the defaults refer to section 4.0.

We will now enter the rest of the events for the school day as shown below. The Bell output has been selected for the rest 
of the events for the day, including morning recess, end of recess, lunch, end of lunch and end of the day.

NOTE: If we had an event we wanted to create which was similar to another event already programmed, we could copy this 
event and then make changes. This can be achieved by using the “Duplicate Event” option (refer to section 5.0 for more 
details).

Fig 14

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 

With the events for the Standard School Day entered, its now a matter of entering the events for the other Event groups 
following the same procedure.

Make sure the configuration is saved and then remove the SD card from the Windows based device following windows safe 
card removal procedures. Make sure the A 4510 is OFF and insert the SD card into the slot in the rear; it will click when fully 
inserted. 

The A 4510 can now be switched On. If all is well, after the startup screen is displayed the current time and list of the  events 
should be displayed on the screen.

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the SD card, so all configuration information will be saved to the SD 
card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to navigate 
to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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4.0 DEFAULTS

It is possible to change the colour scheme of the programming screen and also set default duration times for each of the 
Bell, Prebell, Music and Relay outputs.
Navigate to the “Edit” menu in the top left corner and select “Defaults...” as shown below in figure 15.

Fig 15

The Defaults window should appear as shown below.

From here the Weekday Cell colour, Weekend Cell colour, Month Tile colour and Day Legend colour can be changed to any 
colour in the full colour spectrum.
The default durations for each of the Bell, Prebell, Music and Relay outputs can also be set here. For our example we will set 
the Prebell duration to 4 minutes and 59 seconds, the Bell duration to 3 seconds and the Music duration to 4 minutes and 
59 seconds as shown below. 
Now whenever we create a new Event the duration of the selected output will default to these settings. 
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5.0 DUPLICATING AN EVENT IN A GROUP

In section 3.0 we illustrated the processes involved in creating the Events for a Group (In this case the StandardDay Group). 
With each of the events the start time, duration and output had to entered manually. 
The programming software has the ability to copy (or duplicate) an event which may speed up the process if similar events 
are to be programmed.

This process will be demonstrated in the following example.
As we programmed for the start of the day with a prebell music event, we will do the same for the call to return to class after 
lunch. An event labelled “EndLunchMus” will sound five minutes before the lunch break finishes to notify the students that 
they should start to make their way back to class. For the output of this event we will use the “Music” output. This will use 
the MP3 files in the music folder of the SD card. This can be useful if a different set of music tracks is required for an event.

This event is very similar to the “PrebellMusic” Event we programmed as the first event of the standard day. We will duplicate 
this event and then modify it create an after lunch break event.
Begin by highlighting the “PrebellMusic” Event in the StandardDay Group. Navigate to the “Edit” menu in the top left cor-
ner and then select “Event, Duplicate” as shown in figure 16.

Fig 16

The Duplicate Event window should now appear with the “PrebellMusic” event properties as shown in figure 17.

Fig 17
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We will change the Event name to EndLunchMus and change the start time to five minutes before the end of lunch bell as 
shown in figure 18. We will select the output to the Music folder instead of the Prebell folder as we want to play a series of 
different music files.
NOTE: The Event name can be the same as another event, but the times cannot clash.

Fig 18

The new event now appears in the Event list for StandardDay as shown in figure 19.

Fig 19

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the SD card, so all configuration information will be saved to the SD 
card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to navigate 
to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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6.0 DUPLICATING AN EVENT GROUP

The A 4510 software has a Duplicate Event Group feature which can speed up the programming process. With this function 
any Event Group can be duplicated and then edited. 

In the previous examples a standard school day has been programmed into the timer software.
What if Monday’s timetable was different to the other days of the week because every Monday the school has an assembly. 
We could add another Event Group for Monday’s and program the events for the group manually, or we could use the du-
plicate Event Group function to copy the “Standard Day” Group and then modify the event.
The process will be illustrated by the following example.
We begin by selecting the “StandardDay” Event group from the Event groups window.
The duplicate Event Group feature is accessed by navigating to the “Edit” menu in the top left corner and then selecting 
Event group, Duplicate as shown in figure 20.

Fig 20

The Duplicate Event Group window should now appear with
 the “StandardDay” event group properties as shown in 
figure 21.

        Fig 21

Type in a different name, change the colour and then press OK. For our example we will use the name Mondays and change 
the colour to yellow as shown in figure 22.
NOTE: The same name cannot be used for the new Event Group.

        Fig 22
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The New Mondays Event Group created will now appear in the Event Groups as shown in figure 23.

Fig 23

We will then edit the events for the newly created Mondays Event Group and add an assembly at 9:30 am. Finally the rele-
vant school term Monday’s will be selected on the calendar. The result is shown in figure 24.

Fig 24
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7.0 DAYLIGHT SAVING
The A 4510 has an optional Daylight Saving mode which is entered through the Programming Software.
In Australia, some of the states have Daylight Saving which begins at 2am on the first Sunday in October when clocks are 
put forward one hour. It ends at 2am (which is 3am Daylight Saving Time) on the first Sunday in April, when clocks are put 
back an hour.
To initiate the Daylight Saving mode, press the “Add” button on the bottom left of the programming screen under the Day-
light Saving Window. The Daylight Saving window should appear as shown below.

From here the dates can be entered. Select the date for the clocks to move forward and then press OK. The date should 
appear in the Daylight Saving window. Press the “Add” button again to enter the Daylight Saving window once more and 
enter the date for the clocks to move back an hour and then press OK.
For our example we have selected the dates as shown below.

These dates will then appear as shown below in the Daylight Saving window. Daylight Saving mode is now active and will 
take effect at 2am on the specified dates.  NOTE: The daylight saving dates need to be updated every year.

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 
The calendar is now complete.

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software 
was run. In our case we ran the software directly from the SD card, so all configuration information will be saved to the SD 
card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to navigate 
to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.


